А проапргейдить получится 2.2->2.3?

Аватар пользователя Igor
Не в сети
Регистрация: 5 мая 2013
Сообщения:

Собсно вопрос в заголовке
Получится или все сносить и заново ставить?

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

попробуйте, только бэкап файлов и базы данных перед этим сделайте. админ говорил что если не было сильных изменений вроде все нормально обновляется. расскажите о результатах.

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

способ стандартный для друпала: заливаете файлы, запускаете update.php . желательно перед этим выключить все модули. возможны проблемы с модулем ulogin : у него криво работает установщик (не создает нужную для работы таблицу ее приходится создавать отдельно, при установке этот баг пропатчен, а при обновлении не уверен сработает ли патч) и если у вас на сайте есть пользователи зареганые через этот модуль они потеряют возможность входа, придется вручную сменить им пароли для входа (зацепить свои аккаунты соцсетей они потом смогут в личном кабинете).

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

выложил файл импорта для создания нужной для ulogin таблицы http://dfiles.ru/files/jsx9na4ju

Аватар пользователя Igor
Не в сети
Регистрация: 5 мая 2013
Сообщения:

Отличный ответ-попробуйте:))))
Я понял
сначала на локалке а там посмотрим

Аватар пользователя Igor
Не в сети
Регистрация: 5 мая 2013
Сообщения:

Ну так себе
Пришлось все CSS опять заменять

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

так если вы тему изменяли, надо было сменить ей название и в соответствии с ним папку. тогда бы у вас не заменились бы css файлы или не заменять файлы темы. а в остальном все в порядке? какие были изменения от дефолтового на вашем сайте?

Аватар пользователя Igor
Не в сети
Регистрация: 5 мая 2013
Сообщения:

Сайт пока не трогался
Сейчас озадачусь
пока на локалке обновил

Аватар пользователя Igor
Не в сети
Регистрация: 5 мая 2013
Сообщения:

Поставил на сайт
результат при запуске Update
Fatal error: Call to undefined function drupal_session_start() in /var/www/xxxxxxxxupdate.php on line 649

Аватар пользователя Igor
Не в сети
Регистрация: 5 мая 2013
Сообщения:

Нет
проапгрейдить не получиццо

Failed to create a test table on your MySQL database server with the command CREATE TABLE drupal_install_test (id int NULL). MySQL reports the following message: Table 'drupal_install_test' already exists.
Are you sure the configured username has the necessary MySQL permissions to create tables in the database?
For more help, see the Installation and upgrading handbook. If you are unsure what these terms mean you should probably contact your hosting provider.

Аватар пользователя admin
Не в сети
Регистрация: 8 Июл 2010
Сообщения:

Инструкция по обновлению будет позже. Обновление в стадии тестирования, релиз 2.3 был выпущен раньше, так как там есть исправления ошибок, которые были при установке на php 5.3 и 5.4

Аватар пользователя 2enter
Не в сети
Регистрация: 27 Апр 2012
Сообщения:

есть уже инструкция то?

Гость
Аватар пользователя Гость
brusee написал:
выложил файл импорта для создания нужной для ulogin таблицы http://dfiles.ru/files/jsx9na4ju

перезалей, а то снесли

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

http://dfiles.ru/files/lqws6970c вот, перезалил. а разве он еще требуется? в свежей версии баг с обновлением разве не исправили?

Аватар пользователя Igor
Не в сети
Регистрация: 5 мая 2013
Сообщения:

Ну мне лично страшновато
Все пока работает
А возьмешься обновлять все упадет и чо делать?
зы
я не спамер :))

Гость
Аватар пользователя Гость
brusee написал:
вот, перезалил. а разве он еще требуется? в свежей версии баг с обновлением разве не исправили?

так 2.3 последняя вроде нет? и баг при апргейде с 2.2 на 2.3
Я как раз пытаюсь обновиться

Гость
Аватар пользователя Гость

так баг при накате с 2.2 на 2.3 был или нет?
хочу обновиться, вот и ...

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

баг с недостающей таблицей касается именно обновления модуля ulogin и как следствие обновления всего друшопа. если не было сильных изменений конфигурации то с 2.2 на 2.3 обновляется без проблем, только перед обновлением надо импортировать таблицу для ulogin (файл для импорта выложил выше)

Гость
Аватар пользователя Гость

вот я и попросил Спс.

Отправить комментарий

MultiAuthentication
Содержание этого поля является приватным и не предназначено к показу.