возник глюк

Аватар пользователя m00n_lite
Не в сети
Регистрация: 21 Сен 2010
Сообщения:

Fatal error: Allowed memory size of 50331648 bytes exhausted (tried to allocate 574685 bytes) in /home/xbitecom/public_html/includes/database.mysqli.inc on line 303

мой ломанный английский говорит мне что позволено мне енное число памяти а надо больше

как обойти? я так понимаю это идет установка базы после все походу будет нормально

Аватар пользователя admin
Не в сети
Регистрация: 8 Июл 2010
Сообщения:

мой ломанный английский говорит мне что позволено мне енное число памяти а надо больше

Да, не хватает памяти. Минимально нужно 64 mb, а для корректной работы GD, лучше 128 mb.

как обойти? я так понимаю это идет установка базы после все походу будет нормально

Как вариант:

Создать в корневой директории сайта файл php.ini и в него вписать:

memory_limit = 128M

 

Открыть файл sites/default/settings.php и дописать туда:

ini_set('memory_limit', '128M');

 

Добавить строку в файл .htaccess:

php_value memory_limit 128M

 

Для грамотного хостера может не сработать. Лучше перейти на другой хост (или тариф), так как подобные хосты не расчитаны на серьезные проекты. Рекомендую http://it-patrol.ru/ , хост оптимизирован под drupal, 256 мб памяти. Работает быстрее, чем на локалке. За 100 руб в месяц, считаю очень даже хорошо.

Аватар пользователя m00n_lite
Не в сети
Регистрация: 21 Сен 2010
Сообщения:

большое спасибо за помощь хостер оказался неочень грамотным или попросту ленивым)

через время полюбому перееду на http://it-patrol.ru/

Отправить комментарий

MultiAuthentication
Содержание этого поля является приватным и не предназначено к показу.