Не отображаются картинки у товара

Аватар пользователя Evgeniy
Не в сети
Регистрация: 9 Ноя 2010
Сообщения:

Всем привет

Помогите забороть.

При создании товара. Загрузка изображения происходит нормально. Картинку вижу

Когда все сохраняю картинка в описании товара не видна.

 

Подозреваю что-то с путями проблема и заливается куда-то не туда.

Магазин у становлен в корень виртуал хоста может с этим связано.

 

Подскажите какие настройки проверить

 

спасибо

 

Аватар пользователя atrofimov
Не в сети
Регистрация: 19 Дек 2010
Сообщения:

Скорее всего на Apache не включен режим mod_rewrite и не рабтают "чистые ссылки". Включите mod_rewrite.

Аватар пользователя greatmagway
Не в сети
Регистрация: 3 Июн 2011
Сообщения:

Всем привет!

При создании товара, вижу добавленное изображение, после сохранения выводится только артифакт с ссылкой на него, причём ссылка упирается на файл:   http://maindomen/site/default/files/imagecache/product_full/images/02.06... , такой папки нет, права на весь путь полные. как сэтим бороться?

PS режим mod_rewrite рабтает,  "чистые ссылки" включены

Аватар пользователя hankyshit
Не в сети
Регистрация: 2 Фев 2011
Сообщения:

Подобная же проблема, но немного другого характера:
создаю товар, добавляю картинку, сохраняю. Товар появляется картинка появляется. НО если нажать "подробнее о товаре" никакого подробнее нет =) беда... Нет ни описания, ни картинки, ни цены... а в каталоге все ок... Помогите пожалуйста.

Аватар пользователя admin
Не в сети
Регистрация: 8 Июл 2010
Сообщения:

Нужно смотреть настройки сервера, навскидку ничего сказать не могу, так как не сталкивался с такой проблемой.

Аватар пользователя hankyshit
Не в сети
Регистрация: 2 Фев 2011
Сообщения:

Все ок ... сам виноват испортил файл шаблона случайно. =)

Аватар пользователя Lilac
Не в сети
Регистрация: 5 Фев 2012
Сообщения:

Подобная проблема.
Под админом вижу фото всех товаров.
А под анонимным пользователем фото не отображаются,а если захожу в "Подробнее", фото есть.
Может кто подсказать, в чём причина и как исправить?

Виталий
Аватар пользователя Виталий

добавляя фото в готовую сборку товаров, а так же создавая новый товар, новое фото не отображается
Путь встроенного в шаблон фото- http://имя сайта/sites/default/files/imagefield_thumbs/16.07.2010/wine_glass.jpg?1279269382
и путь нового добавленного в тот же товар--http://имя сайта/sites/default/files/imagefield_thumbs/images/020_0.jpg?1346668812
подскажите что поправить...

Виталий
Аватар пользователя Виталий

я так понимаю что адрес загрузки фото меняется в Настройки/Taxonomy Image-
изменение адреса папки ничего не меняет, всё дело в каких то настройках, только вот в каких?

Виталий
Аватар пользователя Виталий

при наведении мышкой на новое фото пишет-
The requested content cannot be loaded.
Please try again later.

СDen
Аватар пользователя Виталий

Если в базе 14 товаров, то картинки и цена отображается. Добавляю 15 товар. Он добавляется. Но у него на главной странице не отображается цена и фото. Если зайти в сам товар, то цена и фото отображается. Если из базы удалить какой-либо другой товар, то данный(15 товар) товар начинает отображаться корректно. Как будто наложено ограничение на нормальное функционирование только при 14 товарах.
Помогите пожалуйста.

Аватар пользователя Iryna
Не в сети
Регистрация: 24 Янв 2013
Сообщения:

Не отображается картинка товара. Где изменить путь? Скажите пожалуйста. Спасибо.

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

кэш почистите!

Аватар пользователя Iryna
Не в сети
Регистрация: 24 Янв 2013
Сообщения:

Весь кеш очищен. Не оно.
Картинка товара отображается только в редактировании товара.

Аватар пользователя Iryna
Не в сети
Регистрация: 24 Янв 2013
Сообщения:

код картинки ссылается сюда: .../sites/default/files/imagecache/product/images/zagar.jpg , но она сюда не загружается. Если загрузить картинку через ФТП в эту папку — отображается, но некорректно, в реальном размере, не масштабируясь.

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

проверьте права записи на дирректорию /sites/default/files/ и всех поддирректорий должны быть 777 . скорее всего при установке вы этого не сделали. если зайдете в отчеты о работе сайта там будет указано что путь не доступен для записи.
./sites/default/files/imagecache это рабочая дирректория модуля imagecache где он создает уменьшенные копии загруженных картинок.

Аватар пользователя Iryna
Не в сети
Регистрация: 24 Янв 2013
Сообщения:

что-то не помогло. единственная ошибка в отчете: The XML cached files are out of date and need to be regenerated. You can run cron manually to regenerate the sitemap files. Ну я этот крон и запускаю. С картинками никак не соотносится.
Прям не знаю. Обидно.

Аватар пользователя Iryna
Не в сети
Регистрация: 24 Янв 2013
Сообщения:

Короче, файлы картинок нашлись.
Загружаются сюда ... /sites /default /files /images

а код их ищет здесь <.../sites/default/files/imagecache/product/images/

Где это перепрописывается?

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

права доступа на папки проверили? если у вас не создаются картинки в папке ./sites/default/files/imagecache/ в соответствующих подпапках есть только 2 варианта почему это происходит
1)(и наиболее вероятное) модуль imagecache не может записать их туда потому что у него нет прав на запись в соответствующие папки- надо проверять права доступа к папкам на сервере. повторяю должен быть полный доступ (777)
2) на сервере не установлен модуль для работы с изображениями (не помню как называется) - обратитесь в службу поддержки

Аватар пользователя Iryna
Не в сети
Регистрация: 24 Янв 2013
Сообщения:

Безусловно. Везде 777.
Картинки загружаются в две папки в sites /default /files /imagecache /uc_thumbnail, где храниться привьюха для админпанели редактирования товара (отображается, размер изменен)

и в sites /default /files /images без изменения размера.

Код на сайте ищет картинки в другой папке в sites /default /files /imagecache /product /images

вот такая чехарда.

апд. щас проверю модуль из первого варианта. где он там...

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

не сталкивался с такой проблемой (раз измененные картинки создаются значит на сервере нужный модуль присутствует). какая версия друшопа? что меняли в дефолтовых настройках?

Аватар пользователя Iryna
Не в сети
Регистрация: 24 Янв 2013
Сообщения:

Сама ничего не меняла. Единственное что, бом-символы из файла .htaccess удалила программа на хостинге при технической прверке сайта. Может снести все, и поставить заново?

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

попробуйте. скорее всего недогрузился какой-нить файл (правда странно что не выскакивают сообщения об ошибках). про исправление проблем с .htaccess где то на этом форуме уже писали, если в краце: перед заливкой файлов на хостинг открываете его в текстовом редакторе и удаляете все русские комментарии, после этого сохраняете в формате utf8 без бом.

Аватар пользователя Iryna
Не в сети
Регистрация: 24 Янв 2013
Сообщения:

brusee, спасибо за желание помочь. Переустанавливала дважды. Качала оба файла. Наверное придеться отказаться. А жаль.

У товарища Виталия несколько постов выше видимо была аналогичная проблема, значит какой-то сбой бывает и от чего-то зависит.
Что я для себя нарыла:
Как я поняла ImageAPI GD2 совместно с imagecache изменяют размер картинок. Меняют на пять разных рамеров и должны засылать их в соответствующие созданные папки .../imagecache/:
/cart
/product
/product_full
/product_list
/uc_thumbnail
ну, понятно, для отображения или в корзине, или в fancybox, в списке и т.д.
Так вот, у меня выполняется только одно действие, я вижу картинку только в админпанеле редактирования товара. Остальных картинок нет. Также картинки в родном размере заливаются в паку sites /default /files /images, которая находится вне папки /imagecache. Причем после удаления этой папки .../default /files /images, она сама себя создает :)
Проглядела все гляделки в модульных файлах (и не только), не нашла где прописывается путь.
Так что, как-то так:) Блин. Реально жалко. Такая уютная штука. Я конечно еще ночку покумекаю. Снести — дело секундное :)

Еще раз спасибо, brusee.

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

выложите пожалуйста логи сервера и выхлоп phpinfo (последнее можно увидеть если в отчете о работе сайта ткнуться на версию php), а то так гадать че не так можно очень долго. сборка опробована на многих серверах и подобной проблемы не встречалось. видимо не хватает какого то модуля на сервере.

Аватар пользователя Iryna
Не в сети
Регистрация: 24 Янв 2013
Сообщения:

Уже понятно, что ошибка сервера.
зип с логами.

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

похоже у вас в нестройках сервера запрещено применение некоторых дирректив в .htaccess
цитирую:
"Наиболее частой причиной ошибки 500 (Internal Server Error, внутренняя ошибка сервера) является неверный синтаксис файла .htaccess"

откройте .htaccess
попробуйте поочередно закомментировать строки с диррективами Options (поставьте в начале строки #) или закомментируйте все строки с этой диррективой. на nix хоститесь???

Аватар пользователя brusee
Не в сети
Регистрация: 11 Мар 2012
Сообщения:

выложте че выдает phpini() пожалуйста.

Аватар пользователя Iryna
Не в сети
Регистрация: 24 Янв 2013
Сообщения:

PHP 5.3
PHP encoder: Не используется
open_basedir:
output_buffering:
display_errors:
error_reporting:

остальное не отмечено.
Займусь заново сутра.

Аватар пользователя Iryna
Не в сети
Регистрация: 24 Янв 2013
Сообщения:

Привет, brusee. Вобщем забороли. Вдруг кому понадобится расскажу: отключила open_basedir в настройкакх PHP и статические файлы в настройке сайта. Заработали картинки. :)) Зато теперь вылезла кучища других ошибок. Пока порою по форуму, если что — буду справищвать. :)

Аватар пользователя frostbittencrew
Не в сети
Регистрация: 29 Апр 2013
Сообщения:

Здравствуйте.
У меня такая же проблема.
Добавляю товар.
Картинки закачиваются, всё вижу в режиме редактора. На сайте никаких картинок :(
Насчет отключения open_basedir хостер ответил отрицательно. Посоветовал редактировать настройки.
Сразу отвечу на самые популярные советы: всем папкам в files установлены права 777, Кэш очищен и не один раз.
посмотрел урл-ы картинок, которые в режиме редактора видны:
http://мой_сайт/sites/default/files/imagefield_thumbs/images/

на сайте же урл картинки, которая не отображается:
http://мой_сайт/sites/default/files/imagecache/product/images/

урл картинки в превью товара(блок "Похожие товары"):
http://мой_сайт/sites/default/files/imagecache/uc_thumbnail/images/

Как быть?
спасибо..

Отправить комментарий

MultiAuthentication
Содержание этого поля является приватным и не предназначено к показу.